HDU 1087 Super Jumping! Jumping! Jumping!(DP)

Super Jumping! Jumping! Jumping!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48655 Accepted Submission(s): 22531

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)&&n!=0)
    {
        int v[n];
        for(int i=0;i<n;i++)
            scanf("%d",&v[i]);
        int dp[1005];
        memset(dp,0,sizeof(dp));
        int Max=v[0];
        dp[0]=v[0];
        for(int i=1;i<n;i++)
        {
            dp[i]=v[i];//dp[i]表示以i位置结束,上升子序列的最大和
            for(int j=0;j<i;j++)
            {//动归过程就是把当前位置i的点加入到之前比它小的点的dp里看是否会增大
                if(v[j]<v[i]&&dp[i]<dp[j]+v[i])
                    dp[i]=dp[j]+v[i];
            }
            if(Max<dp[i]) Max=dp[i];
        }
        printf("%d\n",Max);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81264467