Super Jumping! Jumping! Jumping! (上升子序列的最大和)

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 

Input

Input contains multiple test cases. Each test case is described in a line as follow: 
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

题意:在长度为n的序列中求上升子序列的最大的字段和。

思路:我们可以模仿求最长上升子序列的方法,遍历整个数组,每次找 确定元素 前的最大和,维护最大值即可。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[1010],dp[1010];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++) //输入数据
            scanf("%d",&num[i]);
        num[0]=0; //最前面的数初始化为0
        int maxx=-1; //最大字段和
        for(int i=1;i<=n;i++) //前i项的最大和为dp[i]
        {
            int maxs=-1;
            for(int j=0;j<i;j++) //在[0,i)中找一个最大的和num[j]<num[i]
                if(num[i]>num[j])
                    maxs=max(maxs,dp[j]);
            dp[i]=maxs+num[i];//以前的最大和加上这个数得到的和
            maxx=max(maxx,dp[i]);//维护最大值
        }
        printf("%d\n",maxx);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41890797/article/details/82084407