E - Red and Black

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/jingmin52296358al/article/details/52117275

E - Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
const int maxn=25,maxm=25;
string map[maxn];
bool visited[maxn][maxm];
int n,m,ans=0;
void search(int row,int col)
{
    if(row<0||row>=n||col<0||col>=m||map[row][col]=='#'||visited[row][col])
        return;
    visited[row][col]=true;
    ++ans;
    search(row-1,col);
    search(row+1,col);
    search(row,col-1);
    search(row,col+1);
}
int main()
{
    cin>>m>>n;
    while(m||n)
    {
        int row,col;
        for(int i=0;i<n;i++)
        {
            cin>>map[i];
            for(int j=0;j<m;j++)
            {

                if(map[i][j]=='@')
                {
                    row=i;
                    col=j;
                }
            }
        }
        memset(visited,false,sizeof(visited));
        ans=0;
        search(row,col);
        cout<<ans<<endl;
        cin>>m>>n;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jingmin52296358al/article/details/52117275