I - Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

题意概括  :红与黑,#代表红色格子,.代表黑色格子,@代表人,人只能走黑色格子而不能走红色格子,问人一共能走多少个格子.

解题思路  :首先找到人所在位置的坐标,然后向四周扩散,记录所能走的点的个数,知道不能走为止.

#include<stdio.h>
#include<string.h>

char a[21][21];
int book[21][21];
int sum,w,h;
int next[4][2] = {0,1,1,0,0,-1,-1,0};

void dfs(int x,int y)
{
    int tx,ty,k;
    
    for(k = 0;k <= 3;k ++)
    {
        tx = x+next[k][0];
        ty = y+next[k][1];
        
        if(tx<0||tx>h-1||ty<0||ty>w-1)
        continue;
        
        if(a[tx][ty] == '.'&&book[tx][ty] == 0)
        {
            sum ++;
            book[tx][ty] = 1;
            dfs(tx,ty);
        }
    }
    return;
}

int main()
{
    int i,j,startx,starty;
    while(~ scanf("%d %d",&w,&h))
    {
        getchar();
        if(w == 0&&h == 0)
        break;
        memset(book,0,sizeof(book));
        for(i = 0;i < h;i ++)
        {
            scanf("%s",a[i]);
        }
        for(i = 0;i < h;i ++)
        {
            for(j = 0;j < w;j ++)
            {
                if(a[i][j] == '@')
                {
                    startx = i;
                    starty = j;
                }
            }
        }
        book[startx][starty] = 1;
        sum = 1;
        
        dfs(startx,starty);
        
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81094590