PAT甲级-1009 Product of Polynomials (25)(25 分)

1009 Product of Polynomials (25)(25 分)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

 解题思路:这题很简单,就直接用2个数组存储第一行和第二行的数据就行,表达不清楚,就是跟多项式求和有点类似,具体的见代码,但我有2个测试点错了,就是因为我后面的结果的数据应该是2000开始往下的,我一开始是1000,导致后面2个测试点错了,解题范围要多注意注意。

#include<bits/stdc++.h>
using namespace std;
double a[1005],b[1005],product[2015];
int main(void)
{
	int k1,k2,e;
	scanf("%d",&k1);
	double x;
	memset(a,0,sizeof a);
	memset(b,0,sizeof b);
	memset(product,0,sizeof product);
	while(k1--)
	{
		scanf("%d%lf",&e,&x);
		a[e]+=x;
	}
	scanf("%d",&k2);
	while(k2--)
	{
		scanf("%d%lf",&e,&x);
		b[e]+=x;
	}
	
	for(int i=0;i<=1000;i++)
	{
		
		for(int j=0;j<=1000;j++)
		{
		   product[i+j]+=a[i]*b[j];
		 } 
	}
	int cnt=0;
	for(int i=0;i<=2000;i++)
	{
		if(product[i]!=0) cnt++;
	}
	printf("%d",cnt);
	for(int i=2000;i>=0;i--)
	{
		if(product[i]!=0)
		printf(" %d %.1lf",i,product[i]);
	}
	putchar('\n');
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82011402
今日推荐