PAT A1009 Product of Polynomials (25分) (C++)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

解题思路:首先定义一个map<int,double> num 接受第一个被乘的多项式组,然后依次接受第二个乘数多项式,遍历num中的元素,依次与乘数相乘,然后将非零项存储到ans中。(其他注意点同A1002 A+B for Polynomials (25分) (C++)

代码如下:

#include<bits/stdc++.h>
using namespace std;
int main(){
	int n;
	scanf("%d",&n);
	map<int,double> num;
	map<int,double> ans;
	for(int i = 0; i < n; i++){
		int exp;
		double coe;
		scanf("%d %lf",&exp,&coe);
		if(coe != 0) num[exp] += coe;   // 输入各个项数 
//		printf("num %d: %d %.1lf\n",i,exp,coe);
	}
	int m;
	scanf("%d",&m);
	for(int i = 0; i < m; i++){
		int exp;
		double coe;
		scanf("%d %lf",&exp,&coe);
		for(map<int,double>::iterator it = num.begin(); it != num.end(); it++){
			int e = it->first;
			double c = it->second;
			ans[e+exp] += c*coe;
			if(ans[e+exp] == 0){
				ans.erase(e+exp);
			}
		}
	}
	if(ans.size() != 0) printf("%d ",ans.size());
	else  printf("%d\n",ans.size());
	for(map<int,double>::iterator it = ans.end(); it != ans.begin();){
		--it;
		if(it != ans.begin()) printf("%d %.1lf ",it->first,it->second);
		else printf("%d %.1lf\n",it->first,it->second);
	}
} 
发布了33 篇原创文章 · 获赞 2 · 访问量 1618

猜你喜欢

转载自blog.csdn.net/qq_38969094/article/details/104320529