PAT甲级 1009. Product of Polynomials (25分)

1009. Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

结尾无空行

Sample Output:

3 3 3.6 2 6.0 1 1.6

结尾无空行
#include <iostream>
using namespace std;

int main()
{
    
    
    int N1, N2;
    cin >> N1;
    double arr[1005] = {
    
    0.0}, ans[2005] = {
    
    0.0};
    int z;
    double x;
    for (int i = 0; i < N1; i++)
    {
    
    
        cin >> z >> x;
        arr[z] = x;
    }
    cin >> N2;
    for (int i = 0; i < N2; i++)
    {
    
    
        cin >> z >> x;
        for (int j = 0; j < 1005; j++)
        {
    
    
            if (arr[j])
            {
    
    
                ans[z + j] += arr[j] * x;
            }
        }
    }
    int count = 0;
    for (int i = 2004; i >= 0; i--)
    {
    
    
        if (ans[i])
        {
    
    
            count++;
        }
    }
    cout << count;
    for (int i = 2004; i >= 0; i--)
    {
    
    
        if (ans[i])
        {
    
    
            printf(" %d %.1f", i, ans[i]);
        }
    }
    system("pause");
    return 0;
}

多项式相乘,与1002的思路一致。

猜你喜欢

转载自blog.csdn.net/leoabcd12/article/details/119733500
今日推荐