PAT - 1007 Maximum Subsequence Sum【最大子列和】

题目

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意

输入序列元素个数并依次输入元素,输出子序列最大的和以及开始值和结束值。

分析

sum为最大和,temp为临时最大和,lindex和rindex为所求的子序列的下标,tempindex标记l的临时下标。temp = temp + v[i],当temp比sum大,就更新sum的值、lindex和rindex的值;当temp < 0,应舍弃temp < 0前面的内容然后令temp = 0,并且同时更新l的临时值tempindex。对于所有的值都为负数的情况要输出0,第一个值,最后一个值,所以在输入的时候用flag判断是不是所有的数字都是小于0的。

代码 

#include <iostream>
#include <vector>
using namespace std;

int main() {
    int n;
    scanf("%d", &n);
    vector<int> v(n);
    int lindex = 0, rindex = n - 1, sum = -1, temp = 0, tempindex = 0;
    for (int i = 0; i < n; i++) {
        scanf("%d", &v[i]);
        temp = temp + v[i];
        if (temp < 0) {
            temp = 0;
            tempindex = i + 1;
        } else if (temp > sum) {
            sum = temp;
            lindex = tempindex;
            rindex = i;
        }
    }
    if (sum < 0) sum = 0;
    printf("%d %d %d", sum, v[lindex], v[rindex]);
    return 0;
}

--------------------- 
作者:柳婼 
来源:CSDN 
原文:https://blog.csdn.net/liuchuo/article/details/52144554 

猜你喜欢

转载自blog.csdn.net/Itskiki/article/details/85047412