PAT A1007 Maximum Subsequence Sum

Description:

Given a sequence of K integers { N​1, N​2, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路:

动态规划题,关键在于找到临界点和状态转移方程

AC代码

#include <stdio.h>

typedef struct
{
    int sum;//和
    int start;//从哪里开始
}Node;

int main()
{
    //freopen("input.txt","r",stdin);
    int N;
    int flag=0;
    scanf("%d",&N);//
    int A[N];
    Node dp[N];
    for(int i=0;i<N;i++)
    {
        scanf("%d",A+i);
        if(A[i]>=0)flag=1;
    }
    if(!flag){
        printf("0 %d %d",A[0],A[N-1]);
        return 0;//退出,不再执行下列语句
    }//数组元素全负
    
    dp[0].sum=A[0];
    dp[0].start=0;
    for(int i=1;i<N;i++)
    {
        if(dp[i-1].sum+A[i]>=A[i])
        {
            dp[i].sum=dp[i-1].sum+A[i];
            dp[i].start=dp[i-1].start;
        }//">="保存最小的i
        else
        {
            dp[i].sum=A[i];
            dp[i].start=i;
        }//状态转移
    }
    int k=0;
    for(int i=1;i<N;i++)
    {
        if(dp[i].sum>dp[k].sum){
            k=i;
        }//此处用">",是为了保存最小的j
    }
    printf("%d %d %d",dp[k].sum,A[dp[k].start],A[k]);
}

发布了54 篇原创文章 · 获赞 1 · 访问量 487

猜你喜欢

转载自blog.csdn.net/weixin_43370733/article/details/103980011