PAT-A 1153 Decode Registration Card of PAT

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/JoJoSIR/article/details/85028233

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4

B123180908127 99

B102180908003 86

A112180318002 98

T107150310127 62

A107180908108 100

T123180908010 78

B112160918035 88

A107180908021 98

1 A

2 107

3 180908

2 999

Sample Output:

Case 1: 1 A

A107180908108 100

A107180908021 98

A112180318002 98

Case 2: 2 107

3 260

Case 3: 3 180908

107 2

123 2

102 1

Case 4: 2 999

NA

题意:

这是一道比较繁琐的排序题,要注意有一个测试点容易超时。

Code:

代码参考:https://blog.csdn.net/qq_41231926/article/details/84945663

#include <stdio.h>
#include <vector>
#include <algorithm>
#include <unordered_map>
#include <string.h>
using namespace std;

struct student{
    char number[14];
    int site;
    int date;
    int score;
};

struct Sites{
    int site, num;
    Sites(int _site, int _num){
        site = _site;
        num = _num;
    }
};

bool cmp1(student a, student b){
    if(a.score != b.score) return a.score > b.score;
    return strcmp(a.number, b.number) < 0;
}

bool cmp2(struct Sites a, struct Sites b){
    if(a.num != b.num) return a.num > b.num;
    if(a.site != b.site) return a.site < b.site;
}

vector<student> filterBySite[1000], filterByLevel[3];
unordered_map<int, vector<student>> filterByDate;
int main(){
    int n, q;
    scanf("%d %d", &n, &q);
    student stu[n];
    for(int i = 0; i < n; i++){
        char card[14];
        scanf("%s %d", &stu[i].number, &stu[i].score);
        stu[i].site = 0;
        int c = 10;
        for(int j = 1; j <= 3; j++)
            stu[i].site = (stu[i].site * c) + stu[i].number[j] - '0';
        stu[i].date = 0;
        for(int j = 4; j <= 9; j++)
            stu[i].date = (stu[i].date * c) + stu[i].number[j] - '0';
        if(stu[i].number[0] == 'T')
            filterByLevel[0].push_back(stu[i]);
        else if(stu[i].number[0] == 'A')
            filterByLevel[1].push_back(stu[i]);
        else filterByLevel[2].push_back(stu[i]);
        filterBySite[stu[i].site].push_back(stu[i]);
        filterByDate[stu[i].date].push_back(stu[i]);
    }
    for(int i = 0; i < 3; i++)
        sort(filterByLevel[i].begin(), filterByLevel[i].end(), cmp1);
    for(int i = 0; i < q; i++){
        int type;
        scanf("%d", &type);
        getchar();
        if(type == 1){
            char L;
            int choose;
            scanf("%c", &L);
            printf("Case %d: %d %c\n", i+1, type, L);
            if(L == 'T') choose = 0;
            else if(L == 'A') choose = 1;
            else choose = 2;
            for(int j = 0; j < filterByLevel[choose].size(); j++)
                printf("%s %d\n", filterByLevel[choose][j].number, filterByLevel[choose][j].score);
            if(filterByLevel[choose].size() == 0) printf("NA\n");
        }else if(type == 2){
            int site;
            scanf("%d", &site);
            printf("Case %d: %d %03d\n", i+1, type, site);
            int sum = 0;
            for(int j = 0; j < filterBySite[site].size(); j++)
                sum += filterBySite[site][j].score;
            if(filterBySite[site].size() == 0) printf("NA\n");
            else printf("%d %d\n", filterBySite[site].size(), sum);
        }else{
            int date;
            scanf("%d", &date);
            printf("Case %d: %d %06d\n", i+1, type, date);
            vector<student> tmpFilterBySite[1000];
            for(int j = 0; j < filterByDate[date].size(); j++){
                tmpFilterBySite[filterByDate[date][j].site].push_back(filterByDate[date][j]);
            }
            vector<Sites> s;
            for(int j = 101; j < 1000; j++){
                if(tmpFilterBySite[j].size() > 0){
                    s.push_back(Sites(j, tmpFilterBySite[j].size()));
                }
            }
            sort(s.begin(), s.end(), cmp2);
            for(int j = 0; j < s.size(); j++)
                printf("%03d %d\n", s[j].site, s[j].num);
            if(s.size() == 0) printf("NA\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/JoJoSIR/article/details/85028233