PAT-A

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zhq9695/article/details/81105402

目录

1003 Emergency (25)(25 分)


1003 Emergency (25)(25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.\ All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<iomanip>
#include<list>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<deque>
#include<algorithm>
using namespace std;
#define MAX 505
#define INF 0x3f3f3f3f

int n,m,c1,c2,a,b,c;
int team[MAX],g[MAX][MAX];
int vis[MAX],dis[MAX];
int ans[MAX],res[MAX];

void dij(){
  memset(res,0,sizeof(res));
  memset(ans,0,sizeof(ans));
  ans[c1]=1;
  res[c1]=team[c1];
  memset(vis,0,sizeof(vis));
  for(int i=0;i<n;i++)dis[i]=INF;dis[c1]=0;
  for(int i=0;i<n;i++){
    int minn=INF,k=-1;
    for(int j=0;j<n;j++)
      if(!vis[j]&&dis[j]<minn)minn=dis[j],k=j;
    if(k==-1)break;
    vis[k]=1;
    for(int j=0;j<n;j++)
      if(!vis[j]&&g[k][j]!=INF){
        if(minn+g[k][j]<dis[j]){
          dis[j]=minn+g[k][j]; // 松弛这个边
          res[j]=res[k]+team[j]; // 队伍数量增加
          ans[j]=ans[k]; // 最短路条数与上个点相同
        }
        else if(minn+g[k][j]==dis[j]){
          ans[j]+=ans[k]; // 可以通过dis[j]的路径或minn+g[k][j]的路径到达,最短路相加
          if(res[k]+team[j]>res[j]) // 比较两种路径的队伍数量,松弛队伍数量
            res[j]=res[k]+team[j];
        }
      }
  }
}

int main(){
  //  freopen("in.txt","r",stdin);
  //  freopen("out.txt","w",stdout);
  cin>>n>>m>>c1>>c2;
  for(int i=0;i<n;i++)cin>>team[i];
  for(int i=0;i<n;i++)
    for(int j=0;j<n;j++){
      if(i==j)g[i][j]=0;
      else g[i][j]=INF;
    }
  while(m--){
    cin>>a>>b>>c;
    g[a][b]=g[b][a]=c;
  }
  dij();
  cout<<ans[c2]<<" "<<res[c2]<<endl;


  return 0;
}





猜你喜欢

转载自blog.csdn.net/zhq9695/article/details/81105402
今日推荐