1153 Decode Registration Card of PAT (25 分)

版权声明: https://blog.csdn.net/ysq96/article/details/89381399

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

思路:

题目给n个学生的card number,和对应的分数。然后有m个询问,每个询问对应的type term不一样,所给的结果集也不一样。这题不难,根据题意就可以写出,分清楚每个type不一样该给出怎样的结果就可以。注意如果有一个点超时,很可能是cout的原因,改成printf即可

C++:

#include"iostream"
#include"vector"
#include"algorithm"
#include"string"
#include"unordered_map" 
using namespace std;
const int maxn=10010;
struct node{
	string name;
	int score;
}li[maxn];
struct node1{
	string site;
	int nt;
	node1(){
		nt=0;
	}
};
bool cmp1(const node &a,const node &b){
	return a.score!=b.score?a.score>b.score:a.name<b.name;
}
bool cmp2(const node1 &a,const node1 &b){
	return a.nt!=b.nt?a.nt>b.nt:a.site<b.site;
}
int main(){
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++){
		string name;
		int temp;
		cin>>name>>temp;
		li[i].name=name;
		li[i].score=temp;
	}
	for(int i=1;i<=m;i++){
		int type,flag=0;
		string term;
		cin>>type>>term;
		printf("Case %d: %d %s\n",i,type,term.c_str());
		if(type==1){
			vector<node> arr;
			for(int j=0;j<n;j++){
				if(li[j].name.substr(0,1)==term)
					arr.push_back(li[j]);
			}
			if(arr.size()!=0){
				flag=1;
				sort(arr.begin(),arr.end(),cmp1);	
				for(node temp:arr)
					printf("%s %d\n",temp.name.c_str(),temp.score);
			}
		}else if(type==2){
			int nt=0,ns=0;
			for(int j=0;j<n;j++){
				if(li[j].name.substr(1,3)==term){
					nt++;
					ns+=li[j].score;
				}
			}
			if(nt!=0){
				flag=1;
				printf("%d %d\n",nt,ns);
			}
		}else if(type==3){
			unordered_map<string,int> m;
			vector<node1> arr;
			for(int j=0;j<n;j++){
				if(li[j].name.substr(4,6)==term){
					string temp=li[j].name.substr(1,3);
					m[temp]++;
				}
			}
			for(auto it=m.begin();it!=m.end();it++){
				node1 temp;
				temp.site=it->first;
				temp.nt=it->second;
				arr.push_back(temp);
			}
			if(arr.size()!=0){
				flag=1;
				sort(arr.begin(),arr.end(),cmp2);
				for(node1 temp:arr)
					printf("%s %d\n",temp.site.c_str(),temp.nt);
			}
		}
		if(flag==0)
			printf("NA\n");
	}
	return 0;
} 
扫描二维码关注公众号,回复: 6220146 查看本文章

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/89381399