1153 Decode Registration Card of PAT (25 分)

1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

考试的时候改了一小时的bug 一直都找不出是什么问题来,最后发现我草 我就拿了21分是因为格式问题,因为我是用数字来排序的所以说输出的时候如果前面是0的话 那么就输出的时候没有这个0所以导致了21分。。。。。哭了

真哭了差4分比如090908  我就输出90908 心里苦

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
const int maxn = 1e4+10;
struct node
{
	char op;
	int room;
	int data;
	int id;
	int score;
	char str[20];
	node(){
		room = data = id = score = 0;
	}
}s[maxn];
bool cmp1(node a, node b){
	if(a.score != b.score)
		return a.score > b.score;
	return strcmp(a.str, b.str) < 0;
}
struct Node{
	int id, cnt;
}a[10000];
bool cmp(Node a, Node b)
{
	if(a.cnt != b.cnt)
		return a.cnt > b.cnt;
	else 
		return a.id < b.id;
}
int main()
{
	int n, m ;
	scanf("%d %d",&n,&m);
	for(int i = 1; i <= n; i ++)
	{
		char str[20];
		scanf("%s %d",str + 1,&s[i].score);
		s[i].op = str[1];
		int gg = 0;
		for(int j = 2; j <= 4; j ++)
			gg = gg * 10 + (str[j] - '0');
		s[i].room = gg; //??..... 
		gg = 0;
		for(int j = 5; j <= 10; j ++)
			gg = gg * 10 + (str[j] - '0');
		s[i].data = gg;
		gg = 0;
		for(int j = 11; j <= 13; j ++)
			gg = gg * 10 + (str[j] - '0');
		s[i].id = gg;
		strcpy(s[i].str,str + 1);
	}
	int cho;
	for(int p = 1; p <= m; p ++)
	{
		scanf("%d",&cho);
		if(cho == 1)
		{
			char kk[5];
			scanf("%s",kk);
			sort(s + 1, s + 1 + n, cmp1);
			int flag = 0;
			printf("Case %d: %d %s\n",p,cho,kk);
			for(int i = 1; i <= n ; i ++)
			{
				if(s[i].op == kk[0])
				{
					printf("%s %d\n",s[i].str,s[i].score);
					flag = 1; 
				}	
			}
			if(!flag)
				printf("NA\n");
		}else if(cho == 2)
		{
			int room;
			scanf("%d",&room);
			int cnt = 0, sum = 0;
			for(int i = 1; i <= n ; i ++)
			{
				if(s[i].room == room)
				{
					cnt ++;
					sum = sum + s[i].score;
				}
			}
			printf("Case %d: %d %d\n",p,cho,room);
			if(cnt != 0 )
				printf("%d %d\n",cnt,sum);
			else 
				printf("NA\n");
		}else if(cho == 3)
		{
			int data;
			scanf("%d",&data);
			map<int,int>mp; 
			for(int i = 1; i <= n ; i ++)
			{
				if(s[i].data == data)
					mp[s[i].room] ++; 
			}
			printf("Case %d: %d %06d\n",p,cho,data);
			if(mp.empty()){
				printf("NA\n");
				continue;
			}
			map<int,int>::iterator it = mp.begin();
			int now = 0;
			while(it != mp.end())
			{
				a[++now].id = it->first;
				a[now].cnt = it->second; 
				it++;
			}
			sort(a + 1,a + 1 + now,cmp);
			for(int i = 1; i <= now; i ++)
				printf("%d %d\n",a[i].id,a[i].cnt);
		}else 
			printf("NA\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/84938681