1153 Decode Registration Card of PAT (25 分)【模拟(易超时)】

1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Termwill be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题意:给card Id,还有一个分数,要从id和分数进行相应的操作,分别有1,2,3等3个操作,具体的看题目

解题思路:模拟,不过这题易超时,所以输入输出尽量用scanf和printf,一开始我用的是cin和cout,但运行超时,只有19分,后面看了别人的代码才知道可以用c_str()函数将string转化成字符串数组,就可以用printf输出(%s),1和2这2个操作很容易模拟,第3个操作需要一个结构体来存储答案,用unordered_map这个容器来对每一个site计数,具体见代码。

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<vector>
#include<unordered_map>
using namespace std;

struct pat{
	string id;
	int score;
};

struct Site{
	string site;
	int count;
};


bool cmp(const pat &a,const pat &b)
{
	return a.score==b.score?a.id<b.id:a.score>b.score;
}
bool cmp1(const Site &a,const Site &b)
{
	return a.count==b.count?a.site<b.site:a.count>b.count;
}

int main(void)
{
	int n,m,type;
	string term;
	
	scanf("%d %d",&n,&m);
	vector<pat>v(n); 
	for(int i=0;i<n;i++)
	{
		cin>>v[i].id>>v[i].score;
    }
    for(int i=1;i<=m;i++)
    {
    	vector<pat>ans; 
    	cin>>type;
    	if(type==1){
    		cin>>term;
    		printf("Case %d: %d %s\n", i, type, term.c_str());
    	//	cout<<"Case "<<i<<": "<<type<<" "<<term<<endl;
    		for(int j=0;j<n;j++)
    		{
    			if(v[j].id[0]==term[0]) ans.push_back(v[j]);
			}
			sort(ans.begin(),ans.end(),cmp);
			if(ans.size()!=0)for(int j=0;j<ans.size();j++) 
			//cout<<ans[j].id<<" "<<ans[j].score<<endl;
		    printf("%s %d\n",ans[j].id.c_str(),ans[j].score);
		    else printf("NA\n");
		}
		else if(type==2){
			cin>>term;
			int count=0,total=0;
			printf("Case %d: %d %s\n", i, type, term.c_str());
		//	cout<<"Case "<<i<<": "<<type<<" "<<term<<endl;
			for(int j=0;j<n;j++)
			{
				if(v[j].id.substr(1,3)==term){
					count++;
					total+=v[j].score;
				}
			}
			if(count==0) {
				cout<<"NA"<<endl;
			}else
			printf("%d %d\n",count,total);
		}
		else if(type==3){
			vector<Site>ans;
			unordered_map<string,int>mapp;
			cin>>term;
			printf("Case %d: %d %s\n", i, type, term.c_str());
			//cout<<"Case "<<i<<": "<<type<<" "<<term<<endl;
		    for(int j=0;j<n;j++)
			{
				
				if(v[j].id.substr(4,6)==term) {
					string s3=v[j].id.substr(1,3);
			        mapp[s3]++;     	
				}
		    }
				for(auto it : mapp)
				ans.push_back({it.first,it.second});
				sort(ans.begin(),ans.end(),cmp1);
				for(int j=0;j<ans.size();j++)
				//cout<<ans[j].site<<" "<<ans[j].count<<endl;
				printf("%s %d\n",ans[j].site.c_str(),ans[j].count);
				//else printf("NA\n");
				 if (ans.size() == 0) printf("NA\n");	
	    }
	}
	return 0;
}
 

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/85370224