1095 解码PAT准考证 (25 分)1153 Decode Registration Card of PAT (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huantonglei/article/details/86409453

PAT 准考证号由 4 部分组成:

  • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 第 2~4 位是考场编号,范围从 101 到 999;
  • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11~13 位是考生编号,范围从 000 到 999。

现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N(≤10​4​​)和 M(≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 英文题:

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Termwill be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

代码如下:


#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;

struct  node {
    string  id;
    int value;
};

bool cmp (const node &a,const node &b)
{
    return a.value!=b.value?a.value>b.value:a.id<b.id;
}

int main()
{
    int N,M,type;
    string s;
    cin>>N>>M;
    vector<node> v(N);
    for (int i=0;i<N;i++)
    {
        cin>>v[i].id>>v[i].value;
    }
    for (int i=1;i<=M;i++)
    {
        cin>>type>>s;
        printf("Case %d: %d %s\n",i,type,s.c_str());
        vector<node> ans;
        int cnt=0,sum=0;
        if (type==1){
            for (int j=0;j<N;j++)
                if (v[j].id[0]==s[0])  ans.push_back(v[j]);
        }
        else if (type==2){
            for (int j=0;j<N;j++){
            if (v[j].id.substr(1,3)==s){
                cnt++;
                sum=sum+v[j].value;
            }
        }
        if(cnt!=0)  printf ("%d %d\n",cnt,sum);
    }
    else if (type==3) {
         unordered_map<string, int> m;
        for (int j=0;j<N;j++){
            if(v[j].id.substr(4,6)==s)
                m[v[j].id.substr(1,3)]++;
        }
        for (auto it : m)
            ans.push_back({it.first, it.second});
    }
    sort (ans.begin(),ans.end(),cmp);
    for (int j=0;j<ans.size();j++)
        printf ("%s %d\n",ans[j].id.c_str(),ans[j].value);
    if(((type==1||type==3)&&ans.size()==0)||(type==2&&cnt==0))
        cout<<"NA"<<endl;
    }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/huantonglei/article/details/86409453