PAT Advanced 1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤) and M (≤), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA



#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
struct stu{
    string num;
    int grade;
};
bool cmp1(const stu& s1,const stu& s2){
    if(s1.grade!=s2.grade) return s1.grade>s2.grade;
    else return s1.num<s2.num;
}
bool cmp3(const pair<string,int>& p1,const pair<string,int>& p2){
    if(p1.second!=p2.second) return p1.second>p2.second;
    else return p1.first<p2.first;
}
int main()
{
    int peo,test;stu tmp;
    int case_num;string case_str;
    cin>>peo>>test;
    vector<stu> vec;
    for(int i=0;i<peo;i++){
        cin>>tmp.num>>tmp.grade;
        vec.push_back(tmp);
    }
    for(int i=1;i<=test;i++){
        cin>>case_num>>case_str;
        printf("Case %d: %d %s\n",i,case_num,case_str.data());
        if(case_num==1){
            vector<stu> vec1;
            for(int j=0;j<peo;j++){
                if(vec[j].num[0]==case_str[0]) vec1.push_back(vec[j]);
            }
            sort(vec1.begin(),vec1.end(),cmp1);
            for(int j=0;j<vec1.size();j++)
                printf("%s %d\n",vec1[j].num.data(),vec1[j].grade);
            if(vec1.size()==0) printf("NA\n");
        }else if(case_num==2){
            int num=0,score=0;
            for(int j=0;j<peo;j++){
                if(vec[j].num.substr(1,3)==case_str){
                    num++;score+=vec[j].grade;
                }
            }
            if(num==0) printf("NA\n");
            else printf("%d %d\n",num,score);
        }else{
            unordered_map<string,int> m;
            for(int j=0;j<peo;j++){
                if(vec[j].num.substr(4,6)==case_str){
                    m[vec[j].num.substr(1,3)]++;
                }
            }
            vector<pair<string,int>> vec3(m.begin(),m.end());
            sort(vec3.begin(),vec3.end(),cmp3);
            for(int i=0;i<vec3.size();i++)
                printf("%s %d\n",vec3[i].first.data(),vec3[i].second);
            if(vec3.size()==0) printf("NA\n");
        }
    }
    system("pause");
    return 0;
}

我这边乙级甲级出现了同样的错误,就是这个NA,应该每个都应该打印。

超时,使用unordered_map,如果还是超时,那么把cout换成printf,如果还是超时,那么把cin换成scanf

猜你喜欢

转载自www.cnblogs.com/littlepage/p/11617820.html