1153 Decode Registration Card of PAT (25分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
#include<iostream>
#include<vector>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<map>
#include<unordered_map>
using namespace std;

typedef pair<int, int> PAIR;

bool cmp_map_count (const PAIR &a, const PAIR &b){

    return a.second != b.second ? a.second > b.second : a.first < b.first;

}

struct case_3_reg_card{


    int site;
    int count;



};

struct case_1_reg_card{


    int score;
    string order;



};
bool cmp_count (case_3_reg_card a, case_3_reg_card b){

    return a.count != b.count ? a.count > b.count : a.site < b.site;

}

struct reg_card{

    char level;
    int site;
    int date;
    int testee_num;
    int score;
    string order;



};


vector<reg_card> test_card;


bool cmp_score(reg_card a, reg_card b){

    return a.score != b.score ? a.score > b.score : a.order < b.order;


}
int main(){
    int n, m;

    cin >> n >> m;

    for(int i = 0; i < n; i++){
        
        reg_card temp_card;
        string temp_s;
        int score;

        cin >> temp_s >> score;
        temp_card.level = temp_s[0];
        temp_card.site = stoi(temp_s.substr(1, 3));
        temp_card.date = stoi(temp_s.substr(4, 6));
        // temp_card.testee_num = stoi(temp_s.substr(10, 13));
        temp_card.score = score;
        temp_card.order = temp_s;
//        case_3[temp_card.site] = 0;
        test_card.push_back(temp_card);
    }

    // for(int i = 0; i < test_card.size(); i++){


    //     cout << test_card[i].level << " " << test_card[i].site << " " << test_card[i].date << " " << test_card[i].testee_num << " " << test_card[i].score << endl;
    // }


    for (int j = 0; j < m; j++)
    {
        int type;
        cin >> type;
       
        if(type == 1){
            
            bool case_1_count = false;
            
            char temp_level;
            cin >> temp_level;
            printf("Case %d: %d %c\n", j + 1, type , temp_level);
            // cout << "Case " << j + 1 << ": " << type << " " << temp_level << endl;
            
            
            sort(test_card.begin(), test_card.end(), cmp_score);
            for(int i = 0; i < test_card.size(); i++){
                
                if(test_card[i].level == temp_level){
                    
                    case_1_count = true;
                    printf("%s %d\n", test_card[i].order.c_str(), test_card[i].score);
                    // cout << test_card[i].order << " " << test_card[i].score << endl;

                }

            }
            if(!case_1_count)

                printf("NA\n");


        }
            

        else if(type == 2){

            int temp_site;
            int count = 0;
            int sum_score = 0;
            cin >> temp_site;
            printf("Case %d: %d %03d\n", j + 1, type , temp_site);
            // cout << "Case " << j + 1 << ": " << type << " " << temp_site << endl;

            for(int i = 0; i < test_card.size(); i++){

                if(test_card[i].site == temp_site){

                    count++;
                    sum_score += test_card[i].score;
                    

                    
                }

            }
            if(count == 0){

                printf("NA\n");

            }else
            {
             
                printf("%d %d\n", count, sum_score);
                // cout << count << " " << sum_score << endl;
            }
            
    
        }
            


        else if(type == 3){
            unordered_map<int, int> case_3;

            int temp_date;
            cin >> temp_date;
            printf("Case %d: %d %06d\n", j + 1, type , temp_date);

            for(int i = 0; i < test_card.size(); i++){


                if(test_card[i].date == temp_date)
                    case_3[test_card[i].site]++;
            }
            vector<case_3_reg_card> vec_case_3;
            for(auto it : case_3)
                vec_case_3.push_back({it.first, it.second});
            sort(vec_case_3.begin(), vec_case_3.end(), cmp_count);

            if(case_3.empty()){

                printf("NA\n");

            }else
            {
                for(int i = 0; i < vec_case_3.size(); i++){

                    printf("%d %d\n", vec_case_3[i].site, vec_case_3[i].count);
                }
            }
            

        }
            


        }
    
    

    return 0;
}
发布了32 篇原创文章 · 获赞 0 · 访问量 442

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104035655