HDU-Fibonacci Again(打表找规律)

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

前三十中被三整除的数

可以清楚的看到n%4==2,即规律。

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>

using namespace std;
int a[104];
int main()
{
	int n;
	while(cin>>n)
	{
		if(n%4==2)
		{
			cout<<"yes"<<endl;
		}
		else
		{
			cout<<"no"<<endl;
		}
	}
	
	
	return 0;
}


 

猜你喜欢

转载自blog.csdn.net/lbperfect123/article/details/86561638