POJ3235Fence Repair( 优先队列 )

优先队列详解点这里

D - Fence Repair

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:有一个农夫要把一个木板钜成几块给定长度的小木板,要求据n-1次,每一次费用就是当前锯的这个木板的长度  

给定小木板的个数n,各个要求的小木板的长度,求最小费用

解释一下样例:

题中给出的数据  8 5 8,按小为优先进入队列即为5 8 8,要费用最小,即每次锯成的两块木板的长度最小(这样他们的和就最小),如题中数据,先选出5 和 8,      5+8=13,ans=ans+13,  13是倒数第一步锯木头的行为的木板长度,  接着 13  8进入队列后自动以小优先排序即为 8 13,   在倒数第二步的锯木头行为 , 8+13=21,     ans=ans+21,    ans这样最终ans 最小取得 34

思路:

用优先队列实现(自动排序)

首先取出两个较小元素,求的和放入队列中,队列此时会重新排一次序,再选两个较小的首元素,直至队列为空

例:

4

4 2 1 3      ans=19

入队自动排序为 1 2 3 4

第一次:取出 1 2 求和 3,3入列,此时队列元素为 3 3 4 (从小到大排序) ans=3;

第二次:取出 3 3 求和 6,6入列,此时队列元素为 4 6                  ans=ans+6=9;

第三次:取出 4 6 求和 10,10入列,此时队列元素为空,结束   ans=ans+10=19;

CODE:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <queue>
using namespace std;

typedef long long LL;

int main()
{
    priority_queue<LL,vector<LL>,greater<LL> >q;
    LL n;

    LL a[20000+10];

    cin>>n;
    for(LL i=0;i<n;i++)
    {
        cin>>a[i];
        q.push(a[i]);
    }

    LL sum=0;

    while(q.size()>1)
    {
        LL date=q.top();
        q.pop();


        LL datee=q.top();
        q.pop();

        date+=datee;

        sum+=date;

        q.push(date);
    }

    cout<<sum<<endl;
}

猜你喜欢

转载自blog.csdn.net/JKdd123456/article/details/83018555