Fence Repair(贪心,优先队列)

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input

   Line 1: One integer 
   N, the number of planks 

Lines 2…
N+1: Each line contains a single integer describing the length of a needed plank
Output

   Line 1: One integer: the minimum amount of money he must spend to make 
   N-1 cuts
  Sample Input3

8
5
8Sample Output34Hint

   He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题目大概是讲一块木板分成N块(L1…LN),每次切割的花费为被切割木板的长度,求最小花费

#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
#include <time.h>
#include <ctype.h>
#include <string.h>
#include <math.h>
#include <string>
#include <queue>
#include <vector>
#define sqr(x) (x)*(x)
#define inf 0x3f3f3f3f
#define PI 3.1415926535
#define mm 20001
using namespace std;
int n,l,ans=0;
int main()
{
 cin>>n;
 priority_queue<int, vector<int>, greater<int> > que; for(int i=0;i<n;i++)
 {
  cin>>l;
  que.push(l);
 }
 while(que.size()>1)
 {
  int l1,l2;
  l1=que.top();
  que.pop();
  l2=que.top();
  que.pop();
  ans+=l1+l2;
  que.push(l1+l2);
 }
 printf("%lld\n",ans);
}
发布了12 篇原创文章 · 获赞 1 · 访问量 198

猜你喜欢

转载自blog.csdn.net/csx_zzh/article/details/105055725
今日推荐