POJ3253 Fence Repair(贪心+优先队列)

Fence Repair

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 60899   Accepted: 20078

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

分析:本体要求求解将木板切割完的最小小开销。即可用二叉树来描述,二叉树的深度以及叶子结点求和即为最小开销。(即最小生成树)的使用。

有以下两种方法可供使用:

1.贪心法:较为麻烦:不断找出最小的两个组合最终得到最小开销。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int N;
int L[22000];
int main()
{
	while (scanf("%d", &N) != EOF)
	{
		long long ans = 0;
		for (int i = 0; i < N; i++)
		{
			scanf("%d", &L[i]);
		}
		int len = N;
		while (len > 1)
		{
			int min1 = 0, min2 = 1;
			if (L[min1] > L[min2])
			{
				swap(min1, min2);
			}
			for (int i = 2; i < len; i++)
			{
				if (L[min1] > L[i])
				{
					min2 = min1;
					min1 = i;
					
				}
				else if (L[min2] > L[i])
				{

					min2 = i;

				}
			}
			int t = L[min1] + L[min2];
			ans += t;
			if (min1 == len - 1)
				swap(min1, min2);
			L[min1] = t;
			L[min2] = L[len - 1];
			len--;
		}
		printf("%lld\n", ans);
	}

	return 0;
}

2.优先队列:用C++的STL构造一个输出最小值的优先队列。然后不断取出最小值进行两两加和得到最小开销;

#include<cstdio>
#include<functional>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int N;
int L[22000];
int main()
{
	while (scanf("%d", &N) != EOF)
	{
		priority_queue<int, vector<int>, greater<int>>que;
		long long ans = 0;
		for (int i = 0; i < N; i++)
		{
			scanf("%d", &L[i]);
			que.push(L[i]);
		}
		while (que.size()>1)
		{
			int m1, m2;
			m1 = que.top();
			que.pop();
			m2 = que.top();
			que.pop();
			int t = m1 + m2;
			ans += t;
			que.push(t);
		}
		cout << ans << endl;
		return 0;
	}
}

猜你喜欢

转载自blog.csdn.net/fighting_yifeng/article/details/81319817
今日推荐