POJ 3253 Fence Repair(贪心,优先队列) - CSDN博客

  

Fence Repair

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 75   Accepted Submission(s) : 15

Problem Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer <i>N</i>, the number of planks <br>Lines 2..<i>N</i>+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make <i>N</i>-1 cuts

Sample Input

 

3 8 5 8

Sample Output

 

34

题意:把一个总长等于输入和的长木板截成输出的长度,每次截的长木板n,需要花费n元,求所需的最小值

思路:使用优先队列(小堆),依次取出两个相加的和压入队列中

#include<cstdio>
#include<queue>
#include<queue>
#include<iostream>
using namespace std;
priority_queue<int,vector<int>,greater<int> >que;
int main()
{
    int n,temp,l,r;
    long long minn=0;
    scanf("%d", &n);
    for (int i = 1; i <= n; i++)
    {
        scanf("%d",&temp);
        que.push(temp);
    }
    while(que.size()>1)
    {
        l=que.top();
        que.pop();
        r=que.top();
        que.pop();
        minn+=(l+r);
        que.push(l+r);
    }
    printf("%lld",minn);
    return 0;
}

Source

PKU

Statistic | Submit | Back

猜你喜欢

转载自blog.csdn.net/sunpeishuai/article/details/81232480
今日推荐