fence repair

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer <i>N</i>, the number of planks <br>Lines 2..<i>N</i>+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make <i>N</i>-1 cuts

Sample Input

 

3 8 5 8

Sample Output

 

34

题目大意,分成指定长度的n份,每次花的钱和每次切割的长度相同

思路,利用贪心和优先队列,每次找最小的两个,合并成一个节点,再继续加入队列中

#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    priority_queue<long long int,vector<long long int>,greater<long long int> >p;
    long long n,a,length=0,sum=0;
    scanf("%lld",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%lld",&a);
        p.push(a);
    }
    while(p.size()>1)
    {
        length=p.top();
        p.pop();
        length+=p.top();
        p.pop();
        sum+=length;
        p.push(length);

    }
    printf("%lld\n",sum);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81111490
今日推荐