2423Fence Repair

Fence Repair

Time Limit: 2000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn\'t own a saw with which to cut the wood, so he mosies over to Farmer Don\'s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn\'t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

 Line 1: One integer N, the number of planks 

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

 Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

Source


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
    int n,i;
    int a[20020];
    scanf("%d",&n);
    for(i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
    }
    long long int a1,a2;
    long long int sum=0;
    priority_queue<int,vector<int>,greater<int> >q;
    for(i=0; i<n; i++)
    {
        q.push(a[i]);
    }
    while(q.size()>1)
    {
        a1=q.top();
        q.pop();
        a2=q.top();
        q.pop();
        sum+=a1+a2;
        q.push(a1+a2);

    }
printf("%lld\n",sum);
return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81805997