POJ-2352 Stars(树状数组应用)

版权声明:如果路过的各位大佬想对菜鸡进行指点请加QQ:3360769137 https://blog.csdn.net/PleasantlY1/article/details/83821294

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:按照y的大小,相等则按照x的大小,有序的给出多个点的坐标,每个坐标表示一颗星星,每颗星星都有等级,它们的等级等于在它们左下角的星星数量。(题目中的图和解释)

思路:这不是二维偏序吗?不对,给出来的已经是有序的坐标,不用再考虑偏序。看下数据范围,暴力是不可能了,那只能想别的方法了。实际上,,,我是来练树状数组才找到这个题的......

树状数组的经典应用是不会的,索引数组是不可能抽象出来的,就只能靠它的基本功能来套题了。因为坐标已经是有序的,所以求等级数就相当于求它前面的星星数,即前缀和。。。用树状数组来实现,求每个星星的前缀和并记录。因为数据有序,所以不用考虑后面的星星会对前面的等级造成影响。无序则需要先进行排序处理。

代码如下:

#include<cmath>
#include<queue>
#include<stack>
#include<deque>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#define per(i,a,b) for(int i=a;i<=b;++i)
#define inf 0xf3f3f3f
#define LL long long 
using namespace std;
int n,p[50005],c[50005];
int lowbit(int k)
{
	return k&(-k);
}
void add(int x,int k)
{
	for(int i=x;i<=50005;i+=lowbit(i))
	c[i]+=k;
}
int sum(int x)
{
	int s=0;
	for(int i=x;i>0;i-=lowbit(i))
	s+=c[i];
	return s; 
}
int main()
{
	int x,y;
	while(cin>>n)
	{
		memset(p,0,sizeof(p));
		memset(c,0,sizeof(c));
		per(i,0,n-1)
		{
			cin>>x>>y;
			x++;//树状数组从1开始 
			p[sum(x)]++;//等级数增加 ,sum是前缀和,c存储的是等级数
			add(x,1);//因为题目保证了数据输入的有序,所以不用管后面输入的会影响前面的前缀
		}
		per(i,0,n-1) printf("%d\n",p[i]);
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/PleasantlY1/article/details/83821294