HDOJ-1398 Square Coins(母函数/DP)

版权声明:欢迎转载,请注出处 https://blog.csdn.net/qq_33850304/article/details/83147901

题目描述

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14544    Accepted Submission(s): 10003


 

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

 

Sample Input

2 10 30 0

Sample Output

1 4 27

题目分析

这道题目可以通过母函数或者DP来实现。

(1)母函数的实现方式比较简单,与模板实现较为类似,这里直接打表再输出即可,但是注意数据范围要稍微开大一点,否则会WA。

(2)动态规划的实现中只需把问题扔给上一步即可,即当前状态(凑出n元)是由上一个状态(凑出了n-i*i元)得来的,只需要把所有的上一个状态加起来即可。

母函数代码实现

#include <iostream>
#include <algorithm>
using namespace std;

int factor[310]={0}, tmp[310]={0};

void pre(){
	int m;
	int money[18] = {0};
	for (int i=0; i<18; i++){
		money[i] = i*i; 
	}	
	fill(factor, factor+310, 1);
	
	for (int i=2; i<=17; i++){
		m = money[i];
		
		for (int j=0; j<=300; j++){//要到300
			for (int k=0; k+j<=300; k+=m){
				tmp[j+k] += factor[j];
			}
		}
		for (int j=0; j<=300; j++){
			factor[j] = tmp[j];
			tmp[j] = 0;
		}
	}
}

int main(){
	int n;
	pre();
	while(cin>>n && n){
		cout<<factor[n]<<endl;
	}
	return 0;
}


动态规划实现

void dp(){
	factor[0] = 1;
	for (int i=1; i<=17; i++){//遍历17种money
		for (int j=1; j<=300; j++){//虽然是从小到大求解,实际却是一直在向小数解扔锅
			if (j - i*i >= 0)
				factor[j] += factor[j-i*i];
		}
	}
}

 

猜你喜欢

转载自blog.csdn.net/qq_33850304/article/details/83147901