Square Coins (母函数)

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

题解: 母函数。

有这么几种面值的金币,分别是1,4,9,16 ……即1^2,2^2,3^2,4^2……每种面值的金币都有无数个,问:给定一个数,用这些金币,有多少种不同的方法能组成这个数。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <cmath>
#include <stack>
#include <queue>
#include <stack>
#define MAX 0x3f3f3f3f
using namespace std;
typedef long long ll;
long long a[1111];
int main()
{

    int n;
    while(cin >> n && n)
    {
       int a[333],b[333];
       for(int i=0;i<=333;i++)
       {
           a[i]=1;             
           b[i]=0;
       }
       for(int i=2;i<=17;i++)
       {
           for(int j=0;j<=n;j++)
           {
               for(int k=0;k+j<=n;k+=i*i)
               {
                   b[k+j]+=a[j];
               }
           }
           for(int j=0;j<=n;j++)
           {
               a[j]=b[j];
               b[j]=0;
           }
       }
       cout << a[n]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/M_Y_Y_/article/details/81206850