Square Coins

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins, 
one 4-credit coin and six 1-credit coins, 
two 4-credit coins and two 1-credit coins, and 
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland. 
InputThe input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300. 
OutputFor each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
Sample Input
2
10
30
0
Sample Output
1
4

27

PS:每个数都可以由小于等于他的平方数加若干个1得到,所以一个数的组合就是小于它的所有平方数的组合个数的和。

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
const int maxn= 3e2+5;
const int mod=1e9;
#define me(a) memset(a,0,sizeof(a))
#define ll long long
using namespace std;
int a[maxn];
int main()
{
   int n;
   int a[35];
   for(int i=1;i*i<=289;i++)
        a[i]=i*i;
   int dp[305];me(dp);
    dp[0]=1;
   for(int i=1;i<=17;i++)
        for(int j=1;j<=300;j++)
            if(j-a[i]>=0)
             dp[j]+=dp[j-a[i]];
    while(cin>>n&&n)
    cout<<dp[n]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/80989982