hdu 1398 Square dfs

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

题意如下:

询问能否用这些木棍拼成正方形。

这个题需要剪枝。

剪枝的情况如下:

(1)总的和余4不等于0,那么一定不能构成

(2)最大值大于他们的平均值,那么一定不能构成

(3)如果三个边都等于平均值,那么一定能构成三角形。

需要注意的是,如果找出一条边的话,那么直接从头开始找。

反之,继续遍历。

代码如下:

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
int m;
int a[25];
int is[25];
int flag=0;
int ave;
int sum;
void dfs (int loc,int ssum,int num)
{
     if(num==3)
     {
        printf("yes\n");
        flag=1;
        return;
     }
     if(ssum==ave)
      {
        dfs(0,0,num+1);
        if(flag)
            return;
      }
     for (int i=loc;i<m;i++)
     {
         if(!is[i]&&ssum+a[i]<=ave)
         {
            is[i]=1;
            dfs(i,ssum+a[i],num);
            is[i]=0;
         }
         if(flag)
            return;
     }
}
int main()
{
    int n;
    scanf("%d",&n);
    while (n--)
    {
        flag=0;
        memset (is,0,sizeof(is));
        sum=0;
        scanf("%d",&m);
        int Max=0;
        for (int i=0;i<m;i++)
           {
               scanf("%d",&a[i]);
               sum+=a[i];
               Max=max(a[i],Max);
           }
        if(sum%4||Max>sum/4)
            printf("no\n");
        else
        {
            ave=sum/4;
            dfs(0,0,0);
          if(!flag)
            printf("no\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81348096