J - Square Coins HDU - 1398

  J - Square Coins HDU - 1398

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27
#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=444;
const int MOD = 1e5+ 7;
int a[N],t[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        memset(a,0,sizeof(a));          /
        memset(t,0,sizeof(t));
        a[0]=1;
        for(int i=1; i*i<=n; i++)
        {
            for(int j=0; j<=n; j++)
            {
                if(a[j])
                {
                    for(int k=0; j+k<=n;k+=i*i)   
                    {
                            t[j+k]+=a[j];
                    }
                }
            }
            memcpy(a,t,sizeof(a));
            memset(t,0,sizeof(t));
        }
        printf("%d\n",a[n]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/clz16251102113/article/details/81210124