HDU 1398 Square Coins(dp:方案数)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13731    Accepted Submission(s): 9449


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input
 
  
2
10
30
0
 

Sample Output
 
  
1
4
27

仍是计算方案数的,做几道下来就感觉有点套路了

#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
int dp[305];
void init()
{
	dp[0]=1;
	for(int i=1;i<=17;i++)
	{//面值到17^2 
		for(int j=i*i;j<305;j++)
		dp[j]+=dp[j-i*i];
	}
	return ;
}
int main()
{
	int n;
	init();
	while(~scanf("%d",&n)&&n)
	{
		printf("%d\n",dp[n]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/bbhhtt/article/details/80416087