HDU 5832 A water problem (高精度取模)

hdu 5832

题目:

Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

Sample Input

 

10001 0 333

Sample Output

 

Case #1: YES Case #2: YES Case #3: NO

题意:10 ^ 10000000级的数, 对73 和 137取模都为零时输出YES, 否则NO.

题解:高精度取模。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e7 + 10;
char s[maxn];
int main()
{
    int cas = 1;
    while(~scanf("%s",s))
    {
        int len = strlen(s);
        int ret1;
        int ret2;
        int num1 = s[0] - '0';
        int num2 = num1;
        for(int i = 1;i < len;i++)
        {

            ret1 = (num1 * 10 + (s[i] - '0')) % 73;
            ret2 = (num2 * 10 + (s[i] - '0')) % 137;
            num1 = ret1;
            num2 = ret2;
        }
        printf("Case #%d: ",cas++);
        if(ret1 == 0 && ret2 == 0)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/LxcXingC/article/details/81666646
今日推荐