HDU-5832-A water problem(大数取模/模拟加法)

A water problem

Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output

For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input

10001
0
333
 

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

解题思路:

没想到竟然是个水题,模拟加法一直取模就行了。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 10000000 + 1;
const int mod = 10001;
char s[maxn];
int main(){
    int cas = 0;
    while(scanf("%s",s) == 1){
        int len = strlen(s);
        int v = 0;
        for (int i = 0; i < len; ++i){
            v = (v*10 + s[i]-48) % mod;
        }
        if (v == 0)
        	printf("Case #%d: YES\n",++cas);
        else 
        	printf("Case #%d: NO\n",++cas);
    }
    return 0;
}
发布了104 篇原创文章 · 获赞 7 · 访问量 4091

猜你喜欢

转载自blog.csdn.net/qq_43461168/article/details/103265922
今日推荐