HDU-1002 A + B Problem II(高精度计算)

版权声明:商业转载请联系作者获得授权,非商业转载请注明出处。 https://blog.csdn.net/weixin_43939327/article/details/85094332

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 452418 Accepted Submission(s): 87699

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

问题简述:

懒得简述了,这题翻译很简单。。

问题分析:

高精度算法。简单来说,就是用一个数组来存一个数,数组的一个元素代表数字的一位,顺便实现一下加法就好。

代码实现:

#include<bits/stdc++.h>
using namespace std;


int a[1005],b[1005];
int main()
{
    int T,i,k,j=1;
    string s1,s2;
    scanf("%d",&T);
    while(T--)
    {
        cin>>s1>>s2;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        a[0]=s1.size();
        b[0]=s2.size();
        for(i=1;i<=a[0];i++)
            a[i]=s1[a[0]-i]-48;
        for(i=1;i<=b[0];i++)
            b[i]=s2[b[0]-i]-48;
        cout<<"Case "<<j++<<":"<<endl;
        cout<<s1<<" + "<<s2<<" = ";
        k=a[0]>b[0]?a[0]:b[0];
        for(i=1;i<=k;i++)
        {
            if(a[i+1]+=(a[i]+b[i])/10);
            a[i]=(a[i]+b[i])%10;
        }
        if(a[k+1]>0) a[0]=k+1;
        else a[0]=k;
        for(i=a[0];i>=1;i--)
            cout<<a[i];
        if(T) cout<<'\n'<<endl;
        else cout<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43939327/article/details/85094332
今日推荐