(string高精度)A + B Problem II hdu1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 399645    Accepted Submission(s): 77352

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

 用JAVA

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n;
        BigInteger a,b;
        n=in.nextInt();
        int i=0;
        while(n>0) {
            n--;
            a=in.nextBigInteger();
            b=in.nextBigInteger();
            i++;
            System.out.println("Case" + " " + i + ":");
            if(n>0) {
                System.out.println(a + " + " + b + " = "+a.add(b));
                System.out.println();
            }
            else {
                System.out.println(a + " + " + b + " = "+a.add(b));
            }
        }
    }
}

C++:

要审清题意,注意输出格式!
#include<string>
#include <cstdio>
#include<iostream>
using namespace std;
string add(string a,string b)
{
    int len1=a.length();
    int len2=b.length();
    if(len1>len2)
    {
        for(int i=1;i<=len1-len2;i++)
            b="0"+b;
    }
    else
    {
        for(int i=1;i<=len2-len1;i++)
            a="0"+a;
    }
    int len=a.length();
    int cf=0,t;
    string str;
    for(int i=len-1;i>=0;i--)
    {
        t=a[i]-'0'+b[i]-'0'+cf;
        cf=t/10;
        t%=10;
        str=char(t+'0')+str;
    }
    if(cf!=0)
        str=char(cf+'0')+str;
    return str;
}
int main()
{
    int t;
    cin>>t;
    int k=0;
    while(t--)
    {
        k++;
        string a,b;
        cin>>a>>b;
        string str;
        str=add(a,b);
        cout<<"Case "<<k<<":"<<endl;
        cout<<a<<" + "<<b<<" = "<<str<<endl;
        if(t)
            cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Weixu-Liu/p/9165365.html
今日推荐