HDU5832 A water problem【大数模除】

A water problem

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5419 Accepted Submission(s): 1768

Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

Sample Input
10001
0
333

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO

Author
UESTC

Source
2016中国大学生程序设计竞赛 - 网络选拔赛

问题链接HDU5832 A water problem
问题简述:(略)
问题分析
    这是一个大数模除问题,需要根据余数定理进行计算。输入的数位数很多,需要用字符串数组来存储。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* HDU5832 A water problem */

#include <stdio.h>

#define MOD 10001
#define N 10000000
char s[N + 1];

int main(void)
{
    int ans, caseno = 0, i;
    while(scanf("%s", s) != EOF) {
        ans = 0;
        for(i = 0; s[i]; i++)
            ans = (ans * 10 + s[i] - '0') % MOD;

        printf("Case #%d: %s\n", ++caseno, ans ? "NO" : "YES");
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10205858.html
今日推荐