HDU 5443 The Water Problem

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/86536577

题目:

In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing 22 integers ll and rr, please find out the biggest water source between alal and arar.

Input

First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000)n(0≤n≤1000) on a line representing the number of water sources. nn integers follow, respectively a1,a2,a3,...,an, and each integer is in {1,...,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be qq lines with two integers ll and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

Output

For each query, output an integer representing the size of the biggest water source.

Sample Input

3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3

Sample Output

100
2
3
4
4
5
1
999999
999999
1

题目大意:

       单点修改,区间查询。

解题思路:

       RMQ模板题。

实现代码:

       

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cmath>
#include<cstring>
using namespace std;

const int N=1000000+5,LogN=20;  //定义整形常量

int logg[N],f[N][LogN+5],a[N];
int n,m,x,y;
int t;
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
    for(int i=1;i<=n;++i){
        scanf("%d",&a[i]);  //读入n个数据
    }

    logg[0]=-1;  //log[0]=-1,这样才能使log[1]为0;

    for(int i=1;i<=n;++i){
        f[i][0]=a[i];
        logg[i]=logg[i>>1]+1; //预处理长度为1-n的log值
    }
    for(int j=1;j<=LogN;++j)    //计算f[i][j]
        for(int i=1;i+(1<<j)-1<=n;++i){ //注意边界不能超过n;
            f[i][j]=max(f[i][j-1],f[i+(1<<j-1)][j-1]);
    }
    scanf("%d",&m);
    while(m--){
        scanf("%d%d",&x,&y);
        int s=logg[y-x+1];
        printf("%d\n",max(f[x][s],f[y-(1<<s)+1][s]));
    }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/86536577