hdu 5443 The Water Problem(求区间最值+ST表)

The Water Problem

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1196    Accepted Submission(s): 942


Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with  a1,a2,a3,...,anrepresenting the size of the water source. Given a set of queries each containing  2 integers  l and  r, please find out the biggest water source between  al and  ar.
 

Input
First you are given an integer  T(T10) indicating the number of test cases. For each test case, there is a number  n(0n1000) on a line representing the number of water sources.  n integers follow, respectively  a1,a2,a3,...,an, and each integer is in  {1,...,106}. On the next line, there is a number  q(0q1000)representing the number of queries. After that, there will be  q lines with two integers  l and  r(1lrn) indicating the range of which you should find out the biggest water source.
 

Output
For each query, output an integer representing the size of the biggest water source.
 

Sample Input
 
  
3 1 100 1 1 1 5 1 2 3 4 5 5 1 2 1 3 2 4 3 4 3 5 3 1 999999 1 4 1 1 1 2 2 3 3 3
 

Sample Output
 
  
100 2 3 4 4 5 1 999999 999999 1
 


没什么说的,ST水题,或者用线段树也可以。

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1550;
int dp[maxn][20],mm[maxn];
int a[maxn], n;
void init()
{
    mm[0] = -1;
    for (int i = 1; i <= n; i++)
    {
        mm[i] = ((i&(i - 1)) == 0) ? mm[i - 1] + 1 : mm[i - 1];
        dp[i][0] = a[i];
    }
    for (int j = 1; j <= mm[n]; j++)
        for (int i = 1; i + (1 << j) - 1 <= n; i++)
        dp[i][j] = max(dp[i][j - 1], dp[i + (1 << (j - 1))][j - 1]);
}
int rmq(int x, int y)
{
    int k = mm[y - x + 1];
    return max(dp[x][k], dp[y - (1 << k) + 1][k]);
}
int main()
{
    int t,q,x,y;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        init();
        scanf("%d", &q);
        while (q--)
        {
            scanf("%d%d", &x, &y);
            printf("%d\n", rmq(x, y));
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_22522375/article/details/51298118