Water problem

Water problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1270    Accepted Submission(s): 522


Problem Description
If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.
 

Output
For each case, print the number of letters would be used.
 

Sample Input
 
  
3 1 2 3
 

Sample Output
 
  
3 6 11
 


PS:

对特殊的情况进行预处理即可.
1~19的英文单词是特殊情况. 20 30 ... 整十是特殊情况. 1000也是特殊情况.
其他的就是由上述单词组合得到. 注意整百时是没有"and"的.
注意细节处理即可.


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<climits>
using namespace std;
int gewei[] = {4,3,3,5,4,4,3,5,5,4,3,6,6,8,8,7,7,9,8,8};
int shiwei[] = {0,0,6,6,5,5,5,7,6,6};
int hund, thou;
int cnt[1100];

int main(int argc, char const *argv[])
{
    //IN;

    hund = 7;
    thou = 8;

    cnt[1000] = 11;
    for(int i=1; i<1000; i++)
    {
        if(i < 20) cnt[i] = gewei[i];
        else if(i < 100)
        {
            int m = i;
            cnt[i] = shiwei[m/10];
            if(m%10) cnt[i] += gewei[m%10];
        }
        else
        {
            int m = i;
            cnt[i] = gewei[m/100] + hund;
            if(!(m%100)) continue;
            cnt[i] += cnt[m%100] + 3;
        }
    }

    for(int i=1; i<=1000; i++)
        cnt[i] += cnt[i-1];

    int t;
    cin >> t;
    while(t--)
    {
        int n;
        scanf("%d", &n);

        printf("%d\n", cnt[n]);
    }

    return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_40510246/article/details/80009096