Poj 2115 C Looooops 扩展欧几里得

Description

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.
 

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

 代码如下:

/*
A+Cx(mod 2^k)=B(mod 2^k)
即:
Cx(mod 2^k)=B-A(mod 2^k);
然后后面是利用扩展欧几里得进行求解....
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
ll aa[35];
ll A,B,C,k;
void Pow_2 ()
{
    aa[0]=1;
    for (int i=1;i<=32;i++)
    {
        aa[i]=aa[i-1]*2;
    }

}
ll Extend (ll A1,ll B1,ll& X,ll& Y)
{
    if(B1==0)
    {
        X=1; Y=0;
        return A1;
    }
    else
    {
        ll temp,ans;
        ans=Extend(B1,A1%B1,X,Y);
        temp=X;
        X=Y;
        Y=temp-A1/B1*Y;
        return ans;
    }
}
int main()
{
    Pow_2();
    while (scanf("%lld%lld%lld%lld",&A,&B,&C,&k)!=EOF&&(A||B||C||k))
    {
        ll a=C,b=aa[k],c=B-A;
        ll x,y;
        ll Gcd=Extend(a,b,x,y);
        if(c%Gcd)
        {
            printf("FOREVER\n");
        }
        else
        {
            x=x*(c/Gcd);
            ll q=b/Gcd;
            printf("%lld\n",(x%q+q)%q);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83006558