POJ-2115-C Looooops【模线性方程】

C Looooops
Description
A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C) statement;I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.
Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0
Sample Output

0
2
32766
FOREVER

**题意:
for(i=A;i!=B;i+=C){i%(2^k)};问你循环执行几次?**

思路: (A+x*C)%(2^k)=B
变形(2^k)*y+B=A+C*x
变形C*x+(-(2^k)*y)=B-A;
ax+by=c;

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;

void exgcd(ll a,ll b,ll &d,ll &x,ll &y)
{
    if(!b)
    {
        d=a;
        x=1;
        y=0;
    }
    else
    {
        exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
int main()
{
    ll A,B,C,K;
    while(~scanf("%lld%lld%lld%lld",&A,&B,&C,&K))

    {
        if(!A &&!B &&!C &&!K)
            break;
        ll a,b,c,d,x,y,m;
        c=B-A;
        if(c==0)
        {
            printf("0\n");
            continue;
        }
        a=C;
        b=(ll)1<<K;
        exgcd(a,b,d,x,y);
        if(c%d)
        {
            printf("FOREVER\n");
            continue;
        }
        m=b/d;
        x=(((x*c/d)%m)+m)%m;
        printf("%lld\n",x);
    }
}

猜你喜欢

转载自blog.csdn.net/li_hongcheng/article/details/79889152