POJ2115 C Looooops(扩展欧几里得)

C Looooops

传送门
A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)
statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0<=x<2k ) modulo 2k .

Input

The input consists of several instances. Each instance is described by a single line with four integers A,B,C,k separated by a single space. The integer k(1<=k<=32) is the number of bits of the control variable of the loop and A,B,C(0<=A,B,C<2k) are the parameters of the loop.
The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER


题意

for(i=A;i!=B;i+=C){i%=(1<<k)};问你循环执行几次,如果无限循环输出 FOREVER

分析

这里就是判断 A+xCB(mod(2k)) 这个方程是不是有解.
我只是随便找一道exgcd的题写写...

CODE

#include<cstdio>
typedef long long LL;

LL Exgcd(LL a,LL b,LL &x,LL &y) {
    if(!b) {x=1;y=0;return a;}
    LL res=Exgcd(b,a%b,y,x);
    y-=x*(a/b);
    return res;
}

int main() {
    LL a,b,c,k,l,d,x,y;
    while(~scanf("%lld %lld %lld %lld",&a,&b,&c,&k)&&(a||b||c||k)) {
        l=1LL<<k;
        d=Exgcd(c,l,x,y);
        if((b-a)%d)puts("FOREVER");
        else {
            x*=((b-a)/d)%l;
            LL r=l/d;
            printf("%lld\n",(x%r+r)%r);
        }
    }
    return 0;
}
发布了34 篇原创文章 · 获赞 44 · 访问量 5071

猜你喜欢

转载自blog.csdn.net/zzyyyl/article/details/78446357