C Looooops POJ - 2115(扩展欧几里徳)

C Looooops POJ - 2115

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.
Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

根据题意可以得到同余式

A + C x B   m o d ( 2 k )
x是所求次数

所以 C x ( B A )   m o d ( 2 k )

C x + 2 k y = B A
利用扩展欧几里徳求解即可

好不容易自己写了会欧几里徳又他妈wa了好几发
原因是 2 k 我用的移位运算
1 << k
但是1是默认int型,k最大32,会溢出
所以要转换格式,应写成
1 L L << k
F U C K !
以后移位运算一定得注意!!!
code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
ll A,B,C,k;
ll ex_gcd(ll a,ll b,ll &x,ll &y){
    if(b == 0){
        x = 1;
        y = 0;
        return a;
    }
    ll gcd = ex_gcd(b,a%b,y,x);
    y -= a / b * x;
    return gcd;
}
int main(){
    while(scanf("%lld%lld%lld%lld",&A,&B,&C,&k) != EOF){
        if(A == 0 && B == 0 && C == 0 && k == 0) break;
        ll a = C;
        ll b = 1LL << k;
        ll c = B - A;
        ll x,y;
        ll gcd = ex_gcd(a,b,x,y);
        if(c % gcd){
            printf("FOREVER\n");
            continue;
        }
        x *= c/gcd;
        b /= gcd;
        if(b < 0) b = -b;
        ll ans = x % b;
        if(ans < 0) ans += b;
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81092528