POJ - 2115 C Looooops

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k. 

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 
Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 
Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0
Sample Output
0
2
32766

FOREVER

扩展欧几里德

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<cmath>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f3f3f
#define maxn 17000
#define root  1,n,1
#define lson  l,mid,rt<<1
#define rson  mid+1,r,rt<<1|1
#define mod  10007
using namespace std;
ll gcd(ll a,ll b){
    return b==0?a : gcd(b,a%b);
}
ll exgcd(ll a,ll b,ll &x,ll &y){
    if(b==0){
        x=1;y=0;return a;
    }
    ll r=exgcd(b,a%b,x,y);
    ll t=x;x=y;
    y=t-a/b*y;
    return r;
}
bool linear(ll a,ll b,ll c,ll &x,ll &y){
    ll d=exgcd(a,b,x,y);
    if(c%d)return false;
    ll k=c/d;
    x*=k;y*=k;
    return true;
}
int main(){
    ll A,B,C,k;
    while(~scanf("%lld%lld%lld%lld",&A,&B,&C,&k)){
        if(A==0&&B==0&&C==0&&k==0)break;
        ll a=C,b=(ll)1<<k,c=B-A,x0,y0;
        bool x=linear(a,b,c,x0,y0);
        if(!x)
            printf("FOREVER\n");
        else{
            b=b/gcd(b,a);
            x0=((x0%b)+b)%b;
            printf("%lld\n",x0);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/lpeaceminusone/article/details/80437071