洛谷 1115 最大子段和、HDU 1003 Max Sum(最大字段和问题)

版权声明:本文为博主原创文章,欢迎转载。如有问题,欢迎指正。 https://blog.csdn.net/weixin_42172261/article/details/88370221

洛谷 1115 最大子段和
题目描述
给出一段序列,选出其中连续且非空的一段使得这段和最大。
输入输出格式
输入格式:
第一行是一个正整数N,表示了序列的长度。
第二行包含N个绝对值不大于10000的整数Ai,描述了这段序列。
输出格式:
一个整数,为最大的子段和是多少。子段的最小长度为1。

#include <iostream>
#include <cstdio>
using namespace std;
int n, maxx, sum, t;
int main()
{
	cin>>n;
	cin>>t;
	maxx=t;
	sum=t;
	for (int i=2; i<=n; i++){
		cin>>t;
		sum=sum>0?sum:0;
		sum+=t;
		maxx=sum>maxx?sum:maxx;
	}
	printf("%d", maxx);
	return 0;
}

HDU 1003 Max Sum
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;

int main()
{
	int T, n;
	scanf("%d", &T);
	for (int k=1; k<=T; k++){
		scanf("%d", &n);
		int t;
		scanf("%d", &t);
		int begin=1, end=1, sum=t, maxx=t, begint=1, endt=1;
		for (int i=2; i<=n; i++){
			scanf("%d", &t);
			if (sum<0){
				sum=0;
				begint=i;
				endt=i;
			}
			sum+=t;
			if (sum>maxx){
				endt=i;
				begin=begint;
				end=endt;
				maxx=sum;
			}
		}
		printf("Case %d:\n", k);
		printf("%d %d %d\n", maxx, begin, end);
		if (k!=T)
			printf("\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_42172261/article/details/88370221