POJ - 1125(Stockbroker Grapevine)

Stockbroker Grapevine

题目链接:

http://poj.org/problem?id=1125

题目:

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39459   Accepted: 22024

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input 

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 
 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题目意思:

给你n个人 在给你每个人传递信息的时间 (注意两个人相互传递信息的时间是不一样的  A传给B的时间  和  B传给A的时间  是不一样的)

要找到一个传递信息给所有人所花时间最短的人 

就对所有人求一遍最短路  用maxtime数组统计每个人所花的最长时间 在找到用时最短的人

如果都不能传给所有人 则输出 disjoint

AC代码:

#include <stdio.h>
#include <string.h>
#include <string.h>
#include <iostream>
#include <queue>
using namespace std;
const int inf = 99999999;
int n,m,maxn,head[105],vis[105],dis[105],b,c,allroad,maxtime[105];
struct r
{
    int e,d,nextroad;
}road[10000];
void add(int a,int b,int c)
{
    road[allroad].e = b;
    road[allroad].d = c;
    road[allroad].nextroad = head[a];
    head[a] = allroad;
}
void SPFA(int a)
{
    for(int i=1;i<=n;i++)
    {
        dis[i] = inf;
        vis[i] = 0;
    }
    dis[a] = 0;
    queue <int> q;
    while(!q.empty()) q.pop();
    q.push(a);
    vis[a] = 1;
    while(!q.empty())
    {
        int now = q.front();
        q.pop(); vis[now] = 0;
        for(int j=head[now] ; j!=-1 ; j=road[j].nextroad)
        {
            int to = road[j].e;
            int dd = road[j].d;
            if((dis[now]+dd)<dis[to])
            {
                dis[to] = dis[now]+dd;
                if(vis[to]==0)
                {
                    q.push(to);
                    vis[to]=1;
                }
            }
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        allroad = 0;
        memset(head,-1,sizeof(head));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&m);
            for(int j=0;j<m;j++)
            {
                scanf("%d%d",&b,&c);
                add(i,b,c); allroad++;
                //注意耗时是单向的 不是双向的
            }
        }
        memset(maxtime,0,sizeof(maxtime));
        for(int i=1;i<=n;i++)
        {
            SPFA(i);//对每个人求一次最短路
            //统计所花最长时间如果这个人不能传给所有人信息 maxtime[i]=0
            int flag=0;
            maxn = 0;
            for(int j=1;j<=n;j++)
            {
                if(j==i)continue;
                if(dis[j]==inf){flag=1;break;}
                maxn = max(maxn,dis[j]);
            }
            if(flag==1);
            else maxtime[i] = maxn;
        }
        //找到耗时最短的人 如果没有输出disjoint
        int flag=0;
        int mintime = inf;
        int minpeople;
        for(int i=1;i<=n;i++)
        {
            if(maxtime[i]!=0)flag=1;
            if(maxtime[i]==0)continue;
            if(maxtime[i]<mintime) {mintime = maxtime[i];minpeople = i;}
        }
        if(flag==1)
            printf("%d %d\n",minpeople,mintime);
        else
            printf("disjoint\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/20172674xi/p/9562801.html