1125:Stockbroker Grapevine

1125:Stockbroker Grapevine

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
输入
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

输出
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
样例输入
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
样例输出
3 2
3 10












扫描二维码关注公众号,回复: 2755255 查看本文章
















































题目数据的输入第一行为n,代表总人数,当n=0时结束程序,接着n行,

第i+1行的第一个是一个整数t,表示第i个人与t个人的关系要好,接着有t对整数,
每对的第一个数是j,表示i与j要好,第二个数是从i直接传递谣言到j所用的时间,
数据的输出是两个整数,第一个为选点的散布谣言的起点,
第二个整数时所有人得知谣言的最短时间
例如,对于数据1,
可知如果从3开始传播,则1,2得知谣言的时间都是2,

所用的时间比从1,2开始传播所用的时间要短,故程序的输出时3 2;


#include "iostream"
#include "stdio.h"
#include "string.h"
using namespace std;
#define Max 110
#define Sky 1<<29
int Map[Max][Max];
int A_max[Max];
int Top;

int main()
{     
       
     // freopen("1.txt","r",stdin);
      while(cin>>Top && Top!=0)
      {   
         int i,j,k;
         memset(Map,0,sizeof(Map));
		 for(i=1;i<=Top;i++)
		 for(j=1;j<=Top;j++)
		 {
         Map[i][j]=Sky;
		 Map[i][i]=0;
		 }		
		 for(i=1;i<=Top;i++)
		 {
		 	int x,y,Num;
		 	cin>>Num;
		 	for(j=1;j<=Num;j++)
		 	{
		        cin>>x>>y;
		   		Map[i][x]=y;
		 	}		 	 
		 }
		         
    	 for(k=1;k<=Top;k++)
    	 {
    	 	for(j=1;j<=Top;j++)
    	 	{
    	 		for(i=1;i<=Top;i++)
    	 		{
    	 			if(k==j || k==i || i==j)
    	 			{
    	 				continue;
    	 			}
    	 			else
    	 			{
    	 			  if(Map[i][j]>Map[i][k]+Map[k][j])
    	 			  {
    	 			  	Map[i][j]=Map[i][k]+Map[k][j];
    	 			  }
    	 			}
    	 		}
    	 	} 
    	 }
         memset(A_max,0,sizeof(A_max));	 
    	 for(i=1;i<=Top;i++)
    	 for(j=1;j<=Top;j++)
    	 {
    	 	  if(Map[i][j]>A_max[i])
    	 	  {
    	 	    A_max[i]=Map[i][j];   	
    	 	 }
    	 	 
    	 }
    	 int Min=A_max[1],Flag=1;
		 for(i=1;i<=Top;i++) 
    	 {
    	 	if( Min>A_max[i] )
    	 	{
    	 		Min=A_max[i];
    	 		Flag=i;
    	 	}
    	 }
		 if(Min==Sky)
		 cout<<"disjoint"<<endl;
		 else
    	 cout<<Flag<<" "<<Min<<endl;
    
      }
      
	
	
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_34125999/article/details/51494333
今日推荐