F - Super Jumping! Jumping! Jumping!

题目:

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

题意:

求解最大递增子序列和,需要注意的是不用是连续的。

这道题一看就是dp。

扫描二维码关注公众号,回复: 3076777 查看本文章

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int num[1010],dp[1010];

int main ()
{
    int n,Max;
    while (~scanf("%d",&n)&&n)
    {
        int i,j;
        Max=0;
        memset(dp,0,sizeof(dp));
        for (i=0; i<n; i++)
        {
            scanf("%d",&num[i]);
        }
        dp[0]=num[0];
        for(i=1; i<n; i++)
        {
            for(j=0; j<i; j++)
            {
                if(num[i]>num[j])
                    dp[i]=max(dp[i],dp[j]+num[i]);
            }
            dp[i]=max(dp[i],num[i]);//很重要,如果比该点的数值小,就保存这点的值;
        }
        for(i=0; i<n; i++)
        {
            Max=max(Max,dp[i]);
        }
        printf("%d\n",Max);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/82082344
今日推荐