1110 Complete Binary Tree(25 分)(cj)

1110 Complete Binary Tree(25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

果然 ! 数组是做完美或完全二叉树的神器!! 

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
using namespace std;
int tree[22][2];
int treearr[22];
bool vis[22];
void init();
int tran(string s);
bool iscomplete(int idex, int pos);
int n;
int main() {
	init();
	cin >> n;
	string a, b;
	for (int i = 0; i < n; ++i) {
		cin >> a >> b;
		if (a != "-") {
			tree[i][0] = tran(a);
			vis[tree[i][0]] = 1;
		}
		if (b != "-") {
			tree[i][1] = tran(b);
			vis[tree[i][1]] = 1;
		}
	}
	int root;
	for (int i = 0; i < n; ++i) {
		if (vis[i] == 0) {
			root = i;
			break;
		}
	}
	if (iscomplete(root,1)) {
		cout << "YES" << ' ' << treearr[n] << endl;
	}
	else {
		cout << "NO" << ' ' << root << endl;
	}
	system("pause");
	return 0;
}
void init() {
	for (int i = 0; i < 22; ++i) {
		tree[i][0] = -1;
		tree[i][1] = -1;
	}
}
int tran(string s) {
	int res = 0;
	for (int i = 0; i < s.size(); ++i) {
		res *= 10;
		res += (s[i] - '0');
	}
	return res;
}
bool iscomplete(int idex, int pos) {
	if (idex == -1) return 1;
	if (pos > n) return 0;
	if (iscomplete(tree[idex][0], pos * 2) == 0) return 0;
	if (iscomplete(tree[idex][1], pos * 2 + 1) == 0) return 0;
	treearr[pos] = idex;
	return 1;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82501982