HDU1385——Minimum Transport Cost 【Floyd,最短路打印路径】

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

 题目大意:给你一个n*n的矩阵,矩阵的每一个元素代表点i——j的距离,-1表示i和j之间无法到达。然后给你一个数组b表示转移到一个城市所需多走的距离,问从c到d所需最小的路程是多少。

大致思路:这道题因为是多组查询,我们可以采用Floyd算法,然后答应最短路径,用一个数组pre[][]记录每一个点后面一个点的位置然后交替输出。

#include <algorithm>
#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
const int MAXN=1100;
const int INF=0x3f3f3f3f;
int maze[MAXN][MAXN],pre[MAXN][MAXN],b[MAXN];
int n;
void get_map(){
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			scanf("%d",&maze[i][j]);
			if(maze[i][j]==-1) 
                maze[i][j]=INF;
			pre[i][j]=j;//记录i后面的点
		}
	}
}
void floyd(){
	for(int k=1;k<=n;k++){
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				if(maze[i][k]+maze[k][j]+b[k]<maze[i][j]){
					maze[i][j]=maze[k][j]+maze[i][k]+b[k];
					pre[i][j]=pre[i][k];
				}
				else if(maze[i][j]==maze[k][j]+maze[i][k]+b[k]){
					pre[i][j]=min(pre[i][j],pre[i][k]);//字典序最小
				}
			}
		}
	}
}
int main(){
	while(~scanf("%d",&n)&&n){
		get_map();
		for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
		floyd();
		int c,d;
		while(~scanf("%d%d",&c,&d)){
			if(c==-1&&d==-1) 
                break;
			printf("From %d to %d :\n",c,d);
			printf("Path: %d",c);
			int u=c,v=d;
			while(c!=d){
                printf("-->%d",pre[c][d]);
                c=pre[c][d];
			}
			printf("\n");
			printf("Total cost : %d\n\n",maze[u][v]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/81712859